Knock sound after taking foot from accelerator - Hyundai Elantra Sport Turbo Forum
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 09-18-2019, 10:14 PM Thread Starter
Member
 
Join Date: Jul 2017
Posts: 33
Knock sound after taking foot from accelerator

I now have around 32k Kms on my 2017 DCT and lately I Am hearing some knock knock or tick sound. It’s either once or twice but in succession. This happens when I accelerate normally from stop and after reaching about 50-60 kmph take my foot off. Immediately I hear either one tick or two tick sounds. Is this coming from the transmission while working on the engaged clutch or something else. It started about a week back. Is it something to worry about or is normal. So far I haven’t had any other issues with the car.
matrix06 is offline  
post #2 of 4 (permalink) Old 09-19-2019, 10:37 PM
Member
 
lurker's Avatar
 
Join Date: Feb 2019
Posts: 74
First thing that comes to mind is the sound of the loud shift motors switching gears, but you did say it happens immediately and i would expect a minor delay between pedal release and the next upshift. Could just be the sound of the entire clutch assemby and geartrain unloading. All the hyundai DCTs are noisey beasts and they dont get any quieter with miles.
lurker is offline  
post #3 of 4 (permalink) Old 09-29-2019, 05:40 PM Thread Starter
Member
 
Join Date: Jul 2017
Posts: 33
Quote:
Originally Posted by lurker View Post
First thing that comes to mind is the sound of the loud shift motors switching gears, but you did say it happens immediately and i would expect a minor delay between pedal release and the next upshift. Could just be the sound of the entire clutch assemby and geartrain unloading. All the hyundai DCTs are noisey beasts and they dont get any quieter with miles.
Most likely its coming from the transmission. Strange thing is that it started coming now, may be after some wear and tear. I hope it doesn't transform into a bigger problem.
matrix06 is offline  
 
post #4 of 4 (permalink) Old 09-30-2019, 11:44 PM
Junior Member
 
Join Date: Jul 2019
Posts: 19
Being optimistic, but did you try checking the motor and transmission mounts. Might need tightened.
gary laser eyes is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Hyundai Elantra Sport Turbo Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome