Elantra Sport Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
78 Posts
Discussion Starter #1
I am noticing my car is taking more “cranks” to fire up on the cold start. Anyone else notice this?
 

·
Registered
Joined
·
78 Posts
Discussion Starter #3
I got an oil change the other day, supposedly was ok on the receipt. I will have Autozone test it to be sure tomorrow.
I wonder how long of a service life everyone is getting on the factory agm battery.
 

·
Registered
Joined
·
2,451 Posts
I got an oil change the other day, supposedly was ok on the receipt. I will have Autozone test it to be sure tomorrow.
I wonder how long of a service life everyone is getting on the factory agm battery.
I got 2 years I believe. Failed suddenly when I was at a car wash. But I live in the desert and heat plays a big role in killing them quicker.
 

·
Registered
Joined
·
78 Posts
Discussion Starter #5
I got 2 years I believe. Failed suddenly when I was at a car wash. But I live in the desert and heat plays a big role in killing them quicker.

Did you replace it with another AGM? I see they have a regular battery option too, but places like Costco don't even list a replacement model for their Interstate batteries.
 

·
Registered
Joined
·
2,451 Posts
Did you replace it with another AGM? I see they have a regular battery option too, but places like Costco don't even list a replacement model for their Interstate batteries.
I bought whatever was available at AutoZone at the time.
 
1 - 7 of 7 Posts
Top