Elantra Sport Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
175 Posts
Discussion Starter · #1 ·
Hello all,

Making a post about our cruise control. I have a 2017 ES MT. The first couple of months after having the car I noticed the cruise would not work occasionally. The pattern I noticed at the time was:

If I turned on the cruise control, and hit set too quickly, or mashed the buttons by accident it disabled cruise control and I would not be able to activate it for a few minutes.

Since the problem never arrised frequently I never followed up on it.

However last night 66,000+ miles of having the car- this happened again. I tried my usual stop engine/turn off car as this got rid of the problem in the past. It did not work this time.

After some frustration and getting off the highway to turn the wheel a bit it started working again. This leads me to believe that it have something to do with the wiring in the steering wheel.

Low and behold I search this up and previous generations have had problems with the electrical wiring in the steering wheel.

Just a friendly heads up for you all. Also, how many have experienced something similar???
 

·
Registered
Joined
·
18 Posts
I have the exact same problem. 18 MT 10000miles

Works well except if I hit both buttons at the same time on too fast, like you. After that, I must shut of the car like you.

Hope someone have that fixed.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top