Elantra Sport Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
2,958 Posts
Not sure what to say, might be time for a dealership visit. 45k miles on my car, I use the cruise control every single day and have had zero issues.
 

·
Registered
Joined
·
27 Posts
I had (might have) the same problem and there was an earlier thread on this. The other forum member stated that the wiring for the cruise control might be a little messed up and if you set the cruise control then modify it immediately it causes an issue. I experienced the same thing and I noticed it was only happening when I would set it then either cancel it immediately or tried to increase/decrease it right after setting it. Afterwards, if I tried to set it again the word set would appear then disappear and it would only work if I turned off my car then tried again. Not sure if your situation is exactly the same but hopefully that helps.
 

·
Registered
Joined
·
14 Posts
Same issue, cruise control doesn't allow me to set it at all anymore. Never had an interment issue.. all the electronics on this car are just failing..(digital clock, rear view camera, etc.) only at 25k miles
 

·
Registered
Joined
·
2,958 Posts
Same issue, cruise control doesn't allow me to set it at all anymore. Never had an interment issue.. all the electronics on this car are just failing..(digital clock, rear view camera, etc.) only at 25k miles
The clock is a glitch. Requires an update from Hyundai.
 

·
Registered
Joined
·
42 Posts
I have the same problem. Under warranty for one more year. Anyone ever resolve this. Turn on cruise, hit set, and goes right off. Got a video of it. Can’t seem to duplicate it. Turn off car and back on resolves it.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top