Elantra Sport Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
50 Posts
Discussion Starter · #1 · (Edited)
I noticed 1 month ago that my OEM BOV spread some oil inside my engine bay. I was concerned about the idea that it come from turbo. I was also concerned about the idea that all the hot side pipe , intercooler core and cold side pipe was completly oil soaked. I had the time yesterday to disasemble all the piping. I found some oil in my intake butterfly valve, cold side pipe and OEM BOV but nothing before. I cleaned all the parts with break cleaner and reassemble it. Now I'm pretty sure that my engine is fine and its just some oil from the PCV valve that goes back in my cold side pipe. I just re-installed my PCV side catch can and I will tell you in a couples of weeks. In case that it can help someone.
 

Attachments

·
Registered
Joined
·
50 Posts
Discussion Starter · #3 ·
That's a lot of oil. Doesn't seem normal.
I had some oil pressure issues with my engine 2 month ago and I'm pretty sure that the dealer doesn't clean the engine intake after the warranty job.
 

·
Registered
Joined
·
66 Posts
Your OCC’s wouldn’t happen to be mounted near the OEM wastegate, would they? If they’re not, I’m wondering if they’re filling and you need to change them out more frequently. More history is needed to root the problem...like when you first installed the OCC’s and when the problem was first noticed along with how many miles you accumulated since installing them.

Which exact OCC’s did you install?
 

·
Registered
Joined
·
50 Posts
Discussion Starter · #5 ·
I removed my PCV side OCC 2 month ago and I just kept my breather side before upload my tune. The oil issue began before I upload the tune and I ran it since January because I doesn't had the time to check it.

My OCC was emptied 1 time per week and was and never completely filled. I don't search a solution. I just know that some members have the same issue and I just want to share if it hapend to another member.

My OCC are a Add W1 V2 style.
 

·
Registered
Joined
·
66 Posts
I noticed some problems with your current setup the way it is now. You say you have a 0+ tune while using HKS M45XL...and I’m thinking your plugs are running too hot. I wouldn’t dare run any tune unless I installed an aftermarket intercooler, but that’s just me. The factory intercooler is too restrictive. You’re running a tune and kept the OEM wastegate...eh, something else I would have changed by using an aftermarket setup. Your signature doesn’t mention anything with regards of your exhaust, so I’m going to assuming you’re using the factory setup. <— something else I would have done different.
 

·
Registered
Joined
·
143 Posts
I noticed 1 month ago that my OEM BOV spread some oil inside my engine bay. I was concerned about the idea that it come from turbo. I was also concerned about the idea that all the hot side pipe , intercooler core and cold side pipe was completly oil soaked. I had the time yesterday to disasemble all the piping. I found some oil in my intake butterfly valve, cold side pipe and OEM BOV but nothing before. I cleaned all the parts with break cleaner and reassemble it. Now I'm pretty sure that my engine is fine and its just some oil from the PCV valve that goes back in my cold side pipe. I just re-installed my PCV side catch can and I will tell you in a couples of weeks. In case that it can help someone.
Hi, did you notice any BPV sticking issue? Lately I feel the slam of the the valve from the BPV when I let of boost. (strange slamming sound and vibration when boost is blowing off)
Now I'm concerned, perhaps I need to see if mine has any oil on it. I have dual catch can on both PCV and Breather side, and both catching oil vapors.
 

·
Registered
Joined
·
2,940 Posts
I noticed some problems with your current setup the way it is now. You say you have a 0+ tune while using HKS M45XL...and I’m thinking your plugs are running too hot. I wouldn’t dare run any tune unless I installed an aftermarket intercooler, but that’s just me. The factory intercooler is too restrictive. You’re running a tune and kept the OEM wastegate...eh, something else I would have changed by using an aftermarket setup. Your signature doesn’t mention anything with regards of your exhaust, so I’m going to assuming you’re using the factory setup. <— something else I would have done different.
Might want to educate yourself on the plugs before saying they are too hot.

Stock intercooler is fine for anything the stock turbo can throw at it. There is plenty of surface area. The only true restriction is on the outlet, where they pinched it down to the size of a quarter.

OEM wastegate (on the turbo) is fine. Mistaken for bypass valve?

Stock exhaust is also fine with the stock turbo. Restrictions being the cats and muffler, the diameter is already 2.5" which is sufficient.
 

·
Registered
Joined
·
50 Posts
Discussion Starter · #9 ·
I noticed some problems with your current setup the way it is now. You say you have a 0+ tune while using HKS M45XL...and I’m thinking your plugs are running too hot. I wouldn’t dare run any tune unless I installed an aftermarket intercooler, but that’s just me. The factory intercooler is too restrictive. You’re running a tune and kept the OEM wastegate...eh, something else I would have changed by using an aftermarket setup. Your signature doesn’t mention anything with regards of your exhaust, so I’m going to assuming you’re using the factory setup. <— something else I would have done different.
I have not done any pool here but I'm pretty sure that we are a lot to run 0 and 0+ tunes on OEM intercooler. I followed all the tuner recommendations before install the tune like the HKS M45XL plugs. I also don't think that I'm on the bad way with the downpipe replacement as recommended by my tuner after asked it what part of the ES exhaust was the most restrictive one.

The FMIC will be replaced soon but will still works as it is for a few months.
 

·
Registered
Joined
·
50 Posts
Discussion Starter · #10 ·
Hi, did you notice any BPV sticking issue? Lately I feel the slam of the the valve from the BPV when I let of boost. (strange slamming sound and vibration when boost is blowing off)
Now I'm concerned, perhaps I need to see if mine has any oil on it. I have dual catch can on both PCV and Breather side, and both catching oil vapors.
Hi, I didn't notice any anormal sound, vibration or sticking. The car always run fine from the first day even if I got that oil issue. I will check the oil level in my PCV OCC this weekend.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top