Elantra Sport Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter · #1 ·
Went to the dealer today because I have the CEL on, and the car have problems regulating the boost. The dealer reset the ECU and said that the code was there because some inappropriate acceleration (all my cars suffer from these type of acceleration:D) and the computer just protect itself. But when I take my car I go WOT on 2nd gear and it start spinning the tires (my complete stock Elantra never do that), but then the computer pull the boost and the fun was over. The car feels great for a moment. Tomorrow I will go again to the dealer for a real diagnostic. Can this problem be a faulty boost control solenoid?
 

·
Registered
Joined
·
92 Posts

·
Registered
Joined
·
92 Posts
@Rapidito, the problem could be the WG solenoid or WG actuator (or line related to).
If you ave a after market solenoid or change the WG actuator adjustment (preload fro greater seal) I suggest to put it back stock before going again to your dealer.

the BOV/BOV solenoid only operated when TB restriction is higher than engine restriction (psi before TB vs psi after TB) nothing related to turbo regulation.
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #6 ·
My car is 100% stock right now. I went last Friday to the dealer, but it was late and they do nothing. I hope that tomorrow they can fix it.

@Rapidito, the problem could be the WG solenoid or WG actuator (or line related to).
If you ave a after market solenoid or change the WG actuator adjustment (preload fro greater seal) I suggest to put it back stock before going again to your dealer..

the BOV/BOV solenoid only operated when TB restriction is higher than engine restriction (psi before TB vs psi after TB) nothing related to turbo regulation.
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #8 ·
Update: The dealer said that they don't have a troubleshooting procedure for this code in the ES, nor the VT, so they call Hyundai Technical Support (or something like that) and they said that the problem is the wastegate. They ordered the part and they will call me then it arrives to install it.
 

·
Registered
Joined
·
23 Posts
Went to the dealer today because I have the CEL on, and the car have problems regulating the boost. The dealer reset the ECU and said that the code was there because some inappropriate acceleration (all my cars suffer from these type of acceleration
) and the computer just protect itself. But when I take my car I go WOT on 2nd gear and it start spinning the tires (my complete stock Elantra never do that), but then the computer pull the boost and the fun was over. The car feels great for a moment. Tomorrow I will go again to the dealer for a real diagnostic. Can this problem be a faulty boost control solenoid?
Mine spins the tires in second as well but only when it warms up outside because tire pressure spikes check your tire pressure mine was at 38 psi because temps rose 50 degrees in 2 days I have noticed quite a bit more torque since I installed my hks bov and flange. So you may want to have them check for a vacuum leak as well they can cause overboost because it doesn't fully actuate the bpv that is in there.
 

·
Registered
Joined
·
2,940 Posts
Mine spins the tires in second as well but only when it warms up outside because tire pressure spikes check your tire pressure mine was at 38 psi because temps rose 50 degrees in 2 days.
It's normal for the tires to be 36-38 psi on a warm day after you've been driving a lot. As long as they are set to 33 cold, you're good.
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #11 ·
My ES with 36-38psi in the front tires don't spin the tires (when making boost from lower rpm's) in 2nd without the help of the clutch . But now I know that with a tune will be possible.

Mine spins the tires in second as well but only when it warms up outside because tire pressure spikes check your tire pressure mine was at 38 psi because temps rose 50 degrees in 2 days I have noticed quite a bit more torque since I installed my hks bov and flange. So you may want to have them check for a vacuum leak as well they can cause overboost because it doesn't fully actuate the bpv that is in there.
 

·
Registered
Joined
·
23 Posts
My ES with 36-38psi in the front tires don't spin the tires (when making boost from lower rpm's) in 2nd without the help of the clutch . But now I know that with a tune will be possible.

Mine spins the tires in second as well but only when it warms up outside because tire pressure spikes check your tire pressure mine was at 38 psi because temps rose 50 degrees in 2 days I have noticed quite a bit more torque since I installed my hks bov and flange. So you may want to have them check for a vacuum leak as well they can cause overboost because it doesn't fully actuate the bpv that is in there.
I dont have a tune and I can't go wot before 4000 in second or the tires rip and I'm banging the limiter
 

·
Registered
Joined
·
23 Posts
Your ES is stock?

I dont have a tune and I can't go wot before 4000 in second or the tires rip and I'm banging the limiter
Other than the hot side resonator delete and an hks bov. I think its over boosting because of a vacuum leak from the bov but I haven't tested it yet waiting for my intake from sxth so I have an excuse to pull the intake and do a boost test
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top