Elantra Sport Forum banner

21 - 30 of 30 Posts

·
Registered
Joined
·
2,290 Posts
When the EBCS gets hot they start to leak, I've felt it on my car when driving for a while, the post are right replace your EBCS, R1600turbo is right!
It's not leaking, just bugging out because of the heat.
 

·
Registered
Joined
·
209 Posts
Like a lot of us have already done, when you replace it with a better one, Borg Warner, move it up and closer to the strut tower, it'll be a lot cooler up there, just extend the vacuum lines to reach.

@R1600
Do you know or have heard on FB what the canister is on the wastegate side line of the ebcs is for?
 

·
Registered
Joined
·
174 Posts
Like a lot of us have already done, when you replace it with a better one, Borg Warner, move it up and closer to the strut tower, it'll be a lot cooler up there, just extend the vacuum lines to reach.

@R1600
Do you know or have heard on FB what the canister is on the wastegate side line of the ebcs is for?
Where can I purchase the Borg Warner upgraded EBCS??
 

·
Registered
Joined
·
2,290 Posts
Like a lot of us have already done, when you replace it with a better one, Borg Warner, move it up and closer to the strut tower, it'll be a lot cooler up there, just extend the vacuum lines to reach.

@R1600
Do you know or have heard on FB what the canister is on the wastegate side line of the ebcs is for?
It's just a filter. You only use 2 of the 3 ports.
 

·
Registered
Joined
·
209 Posts
Awesome thanks R1600
 

·
Registered
Joined
·
76 Posts
I caught mention that this happens moreso when you do back-to-back pulls. If you're in the northern hemisphere, it is still summer and still hot outside. Your computer could be adjusting for elevated IATs from your back to back highway pulls, pulling timing and boost, reducing horsepower to protect the engine. Heat soak is very real on any turbocharged engine. Also, what grade fuel are you using? 87 octane will only amplify knock-retard and will reduce power even more. Only run premium fuel in turbo engines. It may even rectify your concern altogether.
 

·
Registered
Joined
·
209 Posts
Mine was doing this last night also after some back to back pulls.
Almost like sputtering... bloody annoying.

Wish we could work out what it actually is. I've tried improving a few things, swapping parts, nothing really makes any changes.

KDM tuners just bought an ES, might be good to ask them once they start tinkering...
 

·
Registered
Joined
·
2 Posts
I also had the same issue on a long vacation trip this summer. Tried to pass some cars on a steep hill in 4th and the car strugled to keep momentum. This is concerning...
 

·
Registered
Joined
·
209 Posts
Happened at 16 degrees Celsius outside, don't think ambient outside temperature has anything to do with it, also running 98octane fuel. Definitely not knock control.
 

·
Registered
Joined
·
1 Posts
So my 17 es 6spd manual is sputtering after 4k rpm. It seems to be holding power back and jerking me in the car when I floor it after this point. Is this normal for the turbo elantra? I'm at dealer and they say it may be normal for hyundai turbos. They also said that since I have an aftermarket intake and the blow off valve is not connected to the intake that this could be the issue but its only been doing this for a couple months now. I have a 6 inch rubber pipe over the blow off valve and it is venting to atmosphere and have a chair stopper with a clamp around the spot where the hole would be where the blow off valve would connect to the intake. I have been running the car like this for about 6 months or longer now and it just started doing it a short while ago. It mainly jerks me and the rpm jumps around at around 4k when I am in 4th gear and flooring it above 70mph. Please help. The dealer is fucking stupid and has no idea what they are talking about and couldn't give me any advice.

Has anyone else run into this issue at about 70+mph on highway in a manual trans flooring it and the car seems to sputter and jerk you a bit in the car?

Please help!!!
Did you ever figure out the problem? I have a 7 speed auto and the problem your having, is similar to mine, the difference is I notice it at a stop when I begin accelerating.
 
21 - 30 of 30 Posts
Top