Elantra Sport Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
So my motor blew at 15k miles due to a faulty bearing, which dropped a piston into my oil pan. The new motor was installed, and I'm now at 21k miles. My dealer had to fix the turbo water pipe shortly after the new motor install, but this seems unrelated. I'll attach a video tomorrow but basically my car sounds like it has a blow off valve now when I rev it, and under acceleration it feels and sounds like a boost leak or something similar. I also smell the faint scent of exhaust fumes after the turbo has been spooling over 3k rpm in any gear. I do not drive this car hard at all, and I always let it warm up.

I've also had issues where the vehicle hesitates during power delivery almost as if my clutch is rapidly engaging and disengaging at 3k to 5k rpm. I run 93 octane on stock tune but even 91 and 89 gave me similar issues. Thinking it's a spark gap issue or a bad compression ratio for that issue.
 

·
Registered
Joined
·
58 Posts
how do I check for error codes? And yeah I have to take it in tomorrow. It sounds like ****.
I got this https://www.amazon.com/gp/product/B005NLQAHS/ref=oh_aui_detailpage_o00_s00?ie=UTF8&psc=1 with 10,000 purchased and alsmot 5 stars seems pretty good for the price. It works for me no problem youthen get a free app like torque lite, or car scanner, that will connect to the OBD reader. pretty easy. you can then see fault codes and clear them among other things. Car scanner gives way more info for a free app I can't talk about torque pro because I didn't buy it.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top